Joomla! 3.0 and You

Joomla 1.5 to 2.x to 3.x migration.

The Joomla! Project is pleased to announce the immediate availability of Joomla 3.0.0. This is the next major release of the Joomla CMS in the Standard Term Support (STS) track. All 3.0 users will need to plan to update to the new versions available in the STS release cycle every six months until version 3.5 is released. These updates are expected to be simple and backwards compatible.

Who is this release for?

The standard-term releases are designed for users who need access to the new features. Most users with existing 2.5.x sites will not want to update to version 3.0. Users creating new sites can use either version 2.5 or 3.0, depending on which best suits their needs. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use. Also, if you decide to use version 3.0, please be aware that you will need to update your site every six months (to 3.1, 3.2, and so on) until version 3.5 is available. These updates are expected to be simple and backwards compatible.

What is the status of Joomla! 2.5?

Version 2.5 of the Joomla! CMS is a Long Term Support (LTS) release and support for it will continue until shortly after the release of Joomla 3.5, scheduled for Spring 2014. Users on version 2.5 do not need to migrate to Joomla 3.0.

What is the status of Joomla! 1.5?

Support for Joomla 1.5 will end shortly after the release of Joomla 3.0. It is currently supported only for security issues.

Will I be able to update directly from 2.5 to Joomla! 3?

Yes. Any update issues will be a top priority and will likely be resolved early in the 3.x release train. However, it is likely that many templates and extensions for Joomla 2.5 will need modification to work with Joomla 3. Always test prior to migrating and consult with the developers of any extensions and templates you use. Be aware that the technical requirements for running Joomla 3.0 are different. In addition to requiring newer versions of software, certain settings that were once recommmened are now required such as requiring that magic quotes is off. See the Technical Requirements page for the specifications. See the Joomla 3.0.0 Post-Release FAQs for more detailed information about updating from 2.5 to 3.0.

Leave a Comment